Will Blender run on older computers?

Link, Like, Share.

Blender 2.8+ and beyond (Blender 2.9+, 3.x, 4.x et al) is as much of a change from version 2.79 as 2.50 was from 2.49, in that significant parts of the internal rendering system has been rewritten to accommodate more modern systems and effects. Unfortunately this mean it may not run when installed to older computers, desktop or laptop alike, unless the graphics sub-systems support OpenGL 3.3 or above.

IMPORTANT NOTE: unfortunately Blender 2.8 and above to the latest versions will not run on a “Potato PC” so a bigger potato, or an appropriately sized sack of potatoes, preferably of a red or russet variety, will need to be purchased at some point – sadly there is no way to avoid this recipe requirement without burning everything and setting the kitchen on fire.

Design note: generally speaking Blender not running on a given computer is more likely a hardware, rather than software issue (notwithstanding operating system/driver incompatibilities).

How to check Blender compatibility

To check if the “Unsupported graphics driver” error is the actual problem starting Blender 2.8 or above, first determine the systems graphics capabilities. If this is unknown, type “Device Manager” into the Start menu Search bar (or Cortana) and check the “Display adapters” listing, it should read something like “Intel(R) HD Graphics 3000” for example, that’s mid-second generation Intel CPU (2xxx).

Design note: Intel’s graphics infrastructure is a component of the CPU rather than a separate or dedicated external card as might be provided by nVidia or AMD so the nomenclature used may not be specifically generational as that might otherwise be thought; HD 2000, 3000 and some 4000 subsystems for example, can be found on Intel i3/i5/i7 2nd generation CPU’s (e.g. i3 2330, i5 2500 etc.). For NVIDIA, ATI/AMD, most graphics card from NVIDIA‘s 4th generation (and above) support OpenGL 3.x, this includes ‘m’ or mobile class embedded GPUs, i.e. Geforce 405m supports OpenGL 4.5 (3rd generation or below do not support 3.x). For ATI/AMD, cards/mobile modules based on the R500 GPU support OpenGL 3.x, although preference should be for R600 or above as this supports OpenGl 4.x ensuring greater compatibility.

Using this information search the Internet for details. For the above this might bring up this from Intel itself or this from Wikipedia, the upshot being that Intels HD 3000 only supports OpenGL up to 3.1 on Windows (3.3 on Linux). In this instance Blender 2.8 or any version above that won’t run on Windows 7, 8 or 10 resulting in the error seen.

How to fix the Blender compatibility issue

Notwithstanding driver updates, unfortunately the only way to fix or address the issue and get Blender 2.8+ up and running is to update the systems graphics hardware, the graphics card, onboard chipset or component responsible for rendering graphics to something that’s OpenGL 3.3 compatible. For laptop/notebook users this is generally not possible (unless using an MXM module). For desktop users any modern card manufactured within the last few years should be capable of running Blender 2.8+ (cf. above) but double-check before purchase.

OpenGL, Blender 2.9+ & Beyond

Due to Blenders relatively rapid development support for cutting edge features obligate use of relatively modern graphics cards or systems. As a result Blender 2.90, and going forward to all versions of Blender, a compatible graphics card that supports, at minimum, OpenGL 3.3 as discussed above, is REQUIRED. If not, when launched Blender 2.9 et al will display the same Blender – Unsupported Graphics Card of Driver error message. Unfortunately, again as above, this means a graphics system update will be necessary to run newer versions of the application.

Design note: for Linux users OpenGL 3.3 support may be available depending on driver installed.

Blender 2.9 requires OpenGL 3.3
Blender 2.9, and going forward ALL VERSIONS of Blender, require graphics support for OpenGL 3.3 or above.

Blender 2.91 Support

With the introduction of Blender 2.91 a new set of minimum requirements have been brought into effect that means support for OpenGL 3.3, on its own, is no longer sufficient to run Blender. For AMD graphics cards used in particular Blender will ‘crash’ on launch briefly displaying an EXCEPTION_ACCESS_VIOLATION error. If this occurs it exposes a hardware incompatibility due to use of an older chip-set architecture that’s obsolete and longer unsupported by AMD, Terascale instead of the newer GCN series. As this issue is hardware related is cannot be solved with driver updates, and obligates a(nother) hardware upgrade to address.

Important: for Blender 2.91 Intel’s HD Graphics 3000 is no longer supported, the minimum is the HD Graphics 4200 chipset (OpenGL 3.3 support remains).

Design note: crash report/log can be found in C:\Users\[user]\AppData\Local\Temp\blender.crash.txt

Address : 0x000000005B922FB7
Module : atio6axx.dll
Thread : 00002c60
Writing: C:\Users\[user]\AppData\Local\Temp\blender.crash.txt

Blender 2.91 requirements
Blender 2.91 introduces new requirements to run the application else it will ‘crash’ out briefly displaying a fatal error that means support for OpenGL 3.3 or above is no longer sufficient (despite being so for Blender 2.90.x).

Link, Like, Share.