KatsBits Community

wglMakeCurrent: Quake 4 editor and multicore CPUs

kat · 1 · 11376

0 Members and 1 Guest are viewing this topic.

Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2657
    • KatsBits
Multicore CPUs and "wglMakeCurrent failed" error
This is a problem that tends to effect all the various versions of Radiant, the editor used to create levels for id software games; so GTK Radiant, QeRadiant, Quake 4 Edit in particular seems especially prone to problems.

The following message (or similar) will display in the editors console window with one or more of the viewport windows completely unusable - nothing can be drawn or moved around; if attempts are made to do that the console scrolls more text (changing it where appropriate) as each action fails;

Code: [Select]
ERROR: wglMakeCurrent failed.. Error:1282
Please restart Q3Radiant if the Map view is not working

Although it is related to, it's not specifically a problem with the graphics card drivers themselves - i.e. badly installed/uninstalled or corrupted GFX drivers - but instead how the game 'records' what those graphics card system settings are, and oddly, this only seems to happen with systems using multicore CPUs.

When does the problem occur?
Usually just after a driver update or on starting Quake 4's editor (or Radiant) for the first time.
How to fix multicore CPU "wglMakeCurrent failed" error

Try adding the following to the Quake 4 shortcut that starts the editor (right click > properties).

Code: [Select]
+seta r_multisamples 0 +seta r_smp 0
If that doesn't work try deleting the default *.cfg files that are installed to [drive]:[path to]Quake 4q4base; Quake4Config.cfg and editor.cfg and then restarting the editor. That will force the game to rewrite those cfg files with the correct and updated system information allowing the editor to function correctly.

Alternative multi-core fix - punkbuster crash
If after doing all of that you still have problems with the editor suddenly crashing out then it may be an issue with PunkBuster. Rather than delete that service, rename the "pb" folder whilst you're working on a project (just reset it back to "pb" when you want to go only; for some reason there is a file present in there that's crashing out the editor in spite of the known 'fixes' above.