KatsBits Community

Lost furniture nodes

JanXuan · 10 · 13845

0 Members and 1 Guest are viewing this topic.

Offline JanXuan

  • Jr. Member
  • *
    • Posts: 54
Hello,
 
after doing pretty wel with IMVU furniture meshes and a simple room mesh, I took the challenge for a more complicated room.
No problem with the mesh, textures work well. However, there are only a few furniture nodes.
As you can see in the picture on the left side, the 9 floor nodes have a larger orange oval behind them in Pose mode.
I have added extra nodes with Shift+D up to 100. They are all parented to Room rig, and highlight blue in Pose mode.
I have compared the scpecs with the original room template, and I can not find a difference. However in Pose mode they do not have the larger orange oval as you can see in the second column. The connection lines are shown in Object mode.
Do you have a clue why the extra added floor nodes do not work? Sitting and standing poses are OK. I have removed the Wall nodes. Not sure if the Ceiling nodes work, I could not find them yet.


Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2708
    • KatsBits
Double check what they're parented to as it seems from what you said they're parented to the Armature object (Room.RIG?) rather than a bone within it, skeleton.Room, which is why they're not appearing to be linked up - use the Outliner view top-right to do a quick visual check, you should see this;

Code: [Select]
skeleton.Room
» furniture.Floor.[n]

Rather than this;

Code: [Select]
skeleton.Room
furniture.Floor.[n]

In the above, the indentation indicates a 'parent' relationship, the indented item being the Child of the entry above - looking at the Outliner visible in the image you posted it appears you have the second example instead of the first.

To Parent bones, select the Armature and switch to Edit Mode then Shift select the bones to be linked up, the parent LAST (should be highlighted the active object). Press Ctrl+P and select Object (if using nodes instead of bones otherwise it should say 'Bone').

Alternatively, in Edit Mode again, access Object properties and find the Relations options, under Parent: click the orange box input field and select the appropriate bone from the list (or type and it'll display name-related bones).


Offline JanXuan

  • Jr. Member
  • *
    • Posts: 54
Thank you. I have compared it with the prepped template room before I posted this and I could not find a difference, and I still can't.  I attach the complete bone list. As far as I can see their specs are the same as in the template room.


Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2708
    • KatsBits
When you move the Action Editor timeline slider/scrubber back and forth (the vertical green line with the frame number at the bottom) do any of the node appear/dissappear, or does the Scene remain unchanged?


Offline JanXuan

  • Jr. Member
  • *
    • Posts: 54

Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2708
    • KatsBits
Those 'orange ovals' are keyframe markers, they can be deleted and/or reinserted. All you need to do is Select All (A) and press Delete to remove them. Once done move the timeline slider to 'frame "1"' in the Action Editor timeline and press the "I" (i) to Insert the LocRot position of each bone (make sure the cursor is over the 3D View when pressing 'I' after choosing the frame to use). Move the slider to another frame and do the same thing again. That should then give you an exportable file.


Offline JanXuan

  • Jr. Member
  • *
    • Posts: 54
OK, I got them removed, but now I am missing something else.

Now, when I switch back to Object Mode, I do no longer see any relationship lines between the bones.
That seems no good to me, so I saved the mesh to a new name and left the original unchanged.
I need to change some little things on the mesh first.


Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2708
    • KatsBits
Relationship lines don't show in Object Mode only Edit Mode (as a display optimisation otherwise Blender might slow to a crawl). You should be seeing something similar to the below. Read this if you haven't already Making IMVU rooms using Blender 3D (this is for Blender 2.79 or below).

Pose Mode - note no relationship lines

Edit Mode - relationship lines are displayed


Offline JanXuan

  • Jr. Member
  • *
    • Posts: 54
You are right, my bad. Anyway, after removing the orange ovals in Pose Mode, I exported the mesh and things only got worse. Now all nodes are ceiling nodes. I am going to append the mesh in a new empty room and redo the nodes, and see what happens then.


Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2708
    • KatsBits
Read through the tutorial linked above, Making IMVU rooms using Blender 3D, that explains the process extensively so you should be able to checklist where you're going wrong.