Sponsored Adverts

Author Topic: Material or texture problem in IMVU  (Read 1022 times)

0 Members and 1 Guest are viewing this topic.

Offline JanXuan

  • Newbie
  • Posts: 42
Material or texture problem in IMVU
« on: April 13, 2018, 01:31:58 PM »
Hello,

For a few days I am trying to figure out why things don't work, but I am stuck with this problem.

I have a mesh in IMVU containing 6 meshes.
The first 3 meshes come OK with the proper textures, then mesh 4 picks up the texture of mesh 1 (blockFLOOR.MESH), while mesh 5 and six appear white.
All meshes have vertex group Root, modifier Armature and Edge split. (One Edge split missing in the picture has been fixed).
Each mesh has a different material and image.
All meshes load but I only have 3 slots for texture.
I have checked things over and over again and I can't figure out what went wrong.
Can my images give anyone a clue?

Offline kat

  • Administrator
  • Hero Member
  • *
  • Posts: 2286
Re: Material or texture problem in IMVU
« Reply #1 on: April 13, 2018, 11:16:23 PM »
Looking at the Outliner view it appears Blender has auto-appended the original image where it has multiple applications (placed in a number of areas). On export (FBX or CAL) I'm not 100% sure Blender strips that append info or not (the *.001 etc. numbers after *.jpg in the Outliner). If it does it means you've got the same image being physically reference in multiple locations in the resulting file. When that's loaded IMVU will assume and auto-assign the same image to what are then duplicates of the original assignment.

To solve make sure the 'duplicates' are assigned their own distinct Material and/or the image, that itself should mapped to the UV's are unique. In other words where you have [image].jpg.001, try creating a duplicate in Windows/File Explorer and then assigning that to the Material - basically you want several copies of the same image in your project folder each of which is assigned to a specific Material and UV/mesh section.

Nice product design/idea BTW.

Offline JanXuan

  • Newbie
  • Posts: 42
Re: Material or texture problem in IMVU
« Reply #2 on: April 13, 2018, 11:39:46 PM »
I have been wondering about that, however that was not the image that I had assigned to the material. I had a diferent own image for each mesh. I don't know why Blender keeps repeating that image. I'll see if I can change it.
The design is a request, part of a bigger project, Jabba's barge from Star Wars.  :D

Offline JanXuan

  • Newbie
  • Posts: 42
Re: Material or texture problem in IMVU
« Reply #3 on: April 14, 2018, 12:44:35 AM »
Changed the images in 6 unique images, it resulted in a change in that I have now one more texture slot in IMVU and one that was in use before has now gone idle. The telephone box has now texture while the pilar with arm rests now turned white. The trees and vase still have the same image which they should not.

Offline JanXuan

  • Newbie
  • Posts: 42
Re: Material or texture problem in IMVU
« Reply #4 on: April 14, 2018, 12:47:58 AM »
Oh wait a minute, I see something

Offline kat

  • Administrator
  • Hero Member
  • *
  • Posts: 2286
Re: Material or texture problem in IMVU
« Reply #5 on: April 14, 2018, 01:08:14 AM »
Your Material names need to be modified slightly, you can have "block" as the Material name, but you need to change the numerical append "[0]" for all-but-one to be sequential, i.e. "block [1]", "block [2]", "block [3]" and so on (remove the *.001 etc)... Basically IMVU gets its material references from the names given to the Materials in Blender, each of which needs to be 'unique'. See here for a summary of export to FBX - https://www.katsbits.com/tutorials/imvu/furniture-nodes.php#summary

Nice mesh.

Offline JanXuan

  • Newbie
  • Posts: 42
Re: Material or texture problem in IMVU
« Reply #6 on: April 14, 2018, 01:14:39 AM »
OK I will try that. Meanwhile I maneaged to get 6 slots but still working wrong.
The thing that blocked the last 3 slots was a "o" in stead of a "0" (block 4).
That was a tricky one. :)
So here's the situation now. I guess your last advise will fix those errors. :)

Offline JanXuan

  • Newbie
  • Posts: 42
Re: Material or texture problem in IMVU
« Reply #7 on: April 14, 2018, 01:55:55 AM »
I tried the numerical sequence but it did not change anything.
I checked earlier meshes where this was not a problem.
The situation is still the same 2x 2 meshes sharing the same texture) as shown in my last pict

Offline kat

  • Administrator
  • Hero Member
  • *
  • Posts: 2286
Re: Material or texture problem in IMVU
« Reply #8 on: April 14, 2018, 02:22:03 AM »
Keep in mind that IMVU's material list will often display *all* the materials associated with the project per mesh instance, which may look like the assignments are all wonky. You've tried to manually load an XRF into the errant slot yes? You could also try manually editing one of the XRF files to ensure the image referenced is different (doesn't matter what it so so long as its different).

Offline JanXuan

  • Newbie
  • Posts: 42
Re: Material or texture problem in IMVU
« Reply #9 on: April 14, 2018, 09:12:33 AM »
There seems to be a permanent link between mesh blockFLOOR.MESH and mesh blockFLOOR.MESH.003.
I have no idea how, the first was appended as a new block from your sample furniture file. There is no physical connection between the two meshes. Texture slot 01 (IMVU) seems not want to be changed in any way. Manual XRF does not work on it. I can add textures but they won't affect the mesh.

I guess I need to use a texture which does not look bad at both blockFLOOR.MESH and mesh blockFLOOR.MESH.003. Not a perfect solution but I can live with it (both are wood). I can now edit the phone, the phone box, the bed and the pilar with arm rest (also wood). I think it will look ok, but I still would like to once find out what the problem is, because it's giving me a head ache.

And yes, they are nice meshes, the Star Wars stuff is fun to do. I loved doing the Max Rebo band music thingy. :)

Offline JanXuan

  • Newbie
  • Posts: 42
Re: Material or texture problem in IMVU
« Reply #10 on: April 14, 2018, 11:22:35 AM »
As it is now (in peer review).

Offline kat

  • Administrator
  • Hero Member
  • *
  • Posts: 2286
Re: Material or texture problem in IMVU
« Reply #11 on: April 15, 2018, 08:07:32 PM »
Nice!

And yes, Materials and textures can be fiddly to work with. Just make sure to go over everything and check the assignments, also remembering to remove 'dead' references - materials assigned to the Object but not surfaces (in Edit Mode when using the "Select" button nothing is highlighted).

Offline JanXuan

  • Newbie
  • Posts: 42
Re: Material or texture problem in IMVU
« Reply #12 on: April 15, 2018, 09:15:16 PM »
I certainly have to do that with my next project. A bought Airbus A380 mesh whish was not made for IMVU. Deleting a zillion vertices, beaking it up in pieces and I found single parts with 8-10 materials. Keep your fingers crossed. :D

Offline JanXuan

  • Newbie
  • Posts: 42
Re: Material or texture problem in IMVU
« Reply #13 on: April 19, 2018, 09:31:16 PM »
OK, I finished my XB-70 project first.
16 different meshes joined to one and 16 textures came out all right.
No material problems on this one, seems like I have the problem mastered.
Only one little problem, seems like I had a lost pixel on the last mesh, which should be easy to fix.
I had not seen this in Blender but I know where to search for it.
People will love this bird, the cockpit is pretty detailed.

 

Sponsored Adverts
RSS Content is copyright © KatsBits™ 2018 unless otherwise stated. All Rights Reserved.
No part of this web site may be reproduced (except for personal use, or otherwise stated) without prior written permission from KatsBits.com. For more infomation on copyright click here.
Web design cpdtAdvertisePrivacy PolicyDMCA (about DMCA) Home Store Workshops Blog Jobs Support About Katsbits Contact Site Search KatsBits Help Site Map RSS feed Forum YouTube FaceBook LinkedIn Twitter IMVU