Sponsored Adverts

Author Topic: [GTK] problem/solution saving *.map files in Radiant  (Read 6927 times)

0 Members and 1 Guest are viewing this topic.

Online kat

  • Administrator
  • Hero Member
  • *
  • Posts: 2205
[GTK] problem/solution saving *.map files in Radiant
« on: August 22, 2011, 07:05:47 AM »
FIX for GtkRadiant 1.4 map save/load problem
The fix for this odd behaviour is to disable the "Windows" style Open/Save dialogue boxes by doing the following [courtesy of LEM].
  • Click "Edit > Preferences"
  • In "Interface" click "Layout" to access the relevant options
  • Find "Use win32 file load dialog" and deselect the checkbox
  • Click "OK", close and restart Radiant to make sure the setting applied
Problem Description
If you're running Windows Vista and/or Windows 7 there's a general problem that's been around for some time that means GTK Radiant 1.4 won't save new files, forcing users to save over a currently open file. Not ideal. If the above fix doesn't work or the problem seems more persistent than expected, try using Windows Explorer to 'reverse archive' copies of the file being worked on - "[map name] - Copy ([n]).map" - and then simply save over the top of the active file back in Radiant once done (make a copy of the active file [file usually to be opened in radiant], this creates an 'archive' point. Save over the current file. If the map needs to be 'restored' to an earlier point reload one of the copies).

It's also possible to reload and save over the "Autosave.map" file by simply renaming the file to something else, whilst this does work it's not recommended because the application itself automatically saves to that file every "[n]" minutes (usually between 5 or 15 minutes). Note also if the files doesn't exist in the"maps" folder that GtkRadiant 1.4 may have issues saving files.

Alternatively turn on "Snapshots". Be aware that this can result in a lot of file data being generated.

The default Open/Save dialogue uses Windows Explorer which is the root of the problem


In Preferences, deselect "use win32..." option to disable the above


GtkRadiant now defaults to it's own Open/Save dialogue which don't cause problems


Tags:
 

Sponsored Adverts
RSS Content is copyright © KatsBits™ 2017 unless otherwise stated. All Rights Reserved.
No part of this web site may be reproduced (except for personal use, or otherwise stated) without prior written permission from KatsBits.com. For more infomation on copyright click here.
Web design cpdtAdvertisePrivacy PolicyDMCA (about DMCA) Home Store Workshops Blog Jobs Support About Katsbits Contact Site Search KatsBits Help Site Map RSS feed Forum YouTube FaceBook LinkedIn Twitter IMVU