Sponsored Adverts

Author Topic: Missing Textures in-game  (Read 1951 times)

0 Members and 1 Guest are viewing this topic.

Offline kat

  • Administrator
  • Hero Member
  • *
  • Posts: 2334
Missing Textures in-game
« on: June 25, 2015, 11:05:17 PM »
Solution
First of all, I'm not sure if this post belongs here or in the usual level editing forum. But on the other hand, this took me some days to figure out, and I couldn't find any documentation on it.

I added some shaders to the Q3Threewave assets pak, there are some bouncepads in there with red and blue glowing circles, but the ones I need for my map aren't in there. I copied the shader, placed it in my own and changed the source texture.

After adding the new shaders to some faces in my map and compiling it, it does NOT show up in game. I got the feared black and white tile. Must be something I did wrong. Checked the shader again, looks good. In GTK changed the faces again compiled again, you get the picture.

Because I am making this map ready for beta testing, still put the bugged bsp in a pk3 with the textures and shaders.

Guess what... It works. For many of you this might be a perfectly explainable common error, but it cost me some precious mapping hours.

So, if you make shaders of your own and they DON'T work in game:
  • Check the shader again
  • Pack the bsp, textures and shaders in a pk3 file
  • Check if the shaders work in game now
Hope this saves some hours for another n00b mapper

 

Sponsored Adverts
RSS Content is copyright © KatsBits™ 2019 unless otherwise stated. All Rights Reserved.
No part of this web site may be reproduced (except for personal use, or otherwise stated) without prior written permission from KatsBits.com. For more infomation on copyright click here.
Web design cpdtAdvertisePrivacy PolicyDMCA (about DMCA) Home Store Workshops Blog Jobs Support About Katsbits Contact Site Search KatsBits Help Site Map RSS feed Forum YouTube FaceBook LinkedIn Twitter IMVU