Sponsored Adverts

Author Topic: Warning RE_Add Poly To Scene: Null Shader  (Read 2168 times)

0 Members and 1 Guest are viewing this topic.

Offline kat

  • Administrator
  • Hero Member
  • *
  • Posts: 2348
Warning RE_Add Poly To Scene: Null Shader
« on: June 25, 2015, 10:47:20 PM »
Problem
After doing a compile last night I tried to run the new map and half my textures were missing. In the console I was getting this message repeating.

Code: [Select]
Warning RE_Add Poly To Scene: Null Shader
Anyone know what I need to do to fix this. I didn't do a whole lot of changes between the last to compiles. Mostly added some clip textures to a few spots and made a few small new areas. [Pennywise]

Solution
Posted on MapCenter [answered by PJ]
Check this thread, where the same question was answered. (no longer available)

SOF2 may be using an older version of the compiling software. As a part of the Team Arena code, id redid the way that shaders are loaded. Broken shaders were treated as bad script code and broke the game and had to be fixed or removed if they were in the user's game folder.

You may have a broken shader in some script in a pak file. You may have written a bad shader yourself that the SOF2 compile was overlooking. Heck, it may even be a bad shader inside SOF2.

The method is to remove all extra content from your game folder and try to compile. If it works, then add in the files you most want back and try again. Repeat until the compile breaks. The most recently added file is your culprit.

 

Sponsored Adverts
RSS Copyright © 2019 KatsBits™. All Rights Reserved. No part of this or associated properties shall be reproduced without prior consent. AdvertisePrivacy PolicyDMCA (about DMCA) • Copyright PolicyCopyright Contact Home Blog Support About Contact Site Search Site Map RSS feed Forum YouTube FaceBook LinkedIn Twitter Instagram IMVU