Sponsored Adverts

Author Topic: Render Baking issues  (Read 2227 times)

0 Members and 1 Guest are viewing this topic.

Offline ACDmvmkr

  • Newbie
  • Posts: 38
Render Baking issues
« on: December 19, 2013, 04:13:55 AM »
I've been trying to bake shadows onto a model I've created in Blender 2.49b. I've made 23 attempts at it so far.

The model has a jpeg image UV mapped onto it and looks dynamite when rendered. I want to bake the shadows on it so rendering time of animated scenes will be reduced.

I have successfully created a shado image and then used it in a second layer to produce a passable result, but by far the best looking result I got was one I somehow did by accident, but cannot for the life of me seem to do again!
 
I have tried the options of BAKE shadow, and BAKE full render and BAKE texture. The BAKE shadow button seems to work for me with the so-so result, but the truly spectacular result I got was when the entire rendered image with the shadows baked right on to it was produced and saved. This produced a new UV texture image of realistic quality, all the color and lighting qualities perfectly represented as they look whenever I do a straight camera rendering of my model with all the lighting set up and the Ray Shadow option turned on.

That only happened once....and now, it won't ever do it again for me.

I've tried 23 times on this thing, and can't figure out what I'm doing wrong. 21 times I've gotten a straight shadow image produced, once I've gotten the whole full rendered with shadows image, and once I got a message "No image to bake to". Of the 21 times mentioned above, half of them were gotten after clicking the BAKE full render button, but resulted in the shadow only result.

Ive tried loading a new image, not loading a new image with the original texture image loaded, baking while in object mode, and baking while in edit mode, shutting down and re-booting Blender between baking attempts, all starting from a freshly loaded copy of my Blender file. I've followed the instructions from the manual tediously to the letter, and I've scoured YouTube trying to find a tutorial that covers "Full Render Baking" and not just some 7 year old kid's idiot showing of a simple black and white shadow bake. I haven't found one where someone covers a full render baking.

I've been to the Blender Manual 2.4, which only gave general procedures, and followed them to the letter. It seems to work for the BAKE shadows option only, but whenever I choose the BAKE full render option, it simply ignores me and does the BAKE shadows option anyway.

It worked only once doing the BAKE full render option earlier on, but will not do it again. It simply keeps doing the BAKE shadows option no matter which button I click on in the BAKE panel.



This is the result I want but just can't repeat....


This is what I keep getting, so matter what I select on the BAKE panel ("full render" or "shadow", yields the same result)....

"full render" chosen


"shadow" chosen


This is what I get when I choose BAKE "texture" button with the original painted texture mapped to the object....


These are the settings I'm using....







I have fiddled with the above settings trying to land on the right one but....???? no luck....

These are the only instructions I found in the help manual....



What am I missing here?

Thank you;


Offline kat

  • Administrator
  • Hero Member
  • *
  • Posts: 2186
Re: Render Baking issues
« Reply #1 on: December 19, 2013, 08:29:52 AM »
If you're making the attempts successively, i.e. one after the other, then yes, that will happen because Blender is actually 'clearing' the original Texture slot assignment to use the temporary one it creates as a result of the bake. So, do another one after the first and you're actually baking a bake with the result of a baked bake! Say that on a cold night and invoke the god of "huh!?"

If that is what you're doing, and it is what's happening, just re-load the file to clear the bake and 'reset' the texture slot assignments so the original is available for use - I can't remember off the top of mu head if upon saving the bake result you can instruct Blender not to use it as the default image. If you can't you'll need to reset the Texture slot to use the appropriate image rather than the baked one saved.

Also, make sure your mesh is selected when you bake, that's what the "No image to Bake to" error message is about - baking relies on there being an image present and the Object to be baked being selected.

One note though: it's recommended bakes be saved separately and then put together in a photo-editor, that gives much greater control over the result; bakes can produce unexpected results sometimes.

Tags:
 

Sponsored Adverts
RSS Content is copyright © KatsBits™ 2017 unless otherwise stated. All Rights Reserved.
No part of this web site may be reproduced (except for personal use, or otherwise stated) without prior written permission from KatsBits.com. For more infomation on copyright click here.
Web design cpdtAdvertisePrivacy PolicyDMCA (about DMCA) Home Store Workshops Blog Jobs Support About Katsbits Contact Site Search KatsBits Help Site Map RSS feed Forum YouTube FaceBook LinkedIn Twitter IMVU