Sponsored Adverts

Author Topic: [CoD4] uv mapping trouble  (Read 3907 times)

0 Members and 1 Guest are viewing this topic.

Offline yeedoo

  • Defunct
  • Newbie
  • Posts: 18
[CoD4] uv mapping trouble
« on: November 20, 2010, 12:37:03 PM »
hi all! i am playing with cod4radiant. I make a model and uv map it in blender2.49, then EXPORT it to .obj (shown in shot below)

http://www.screencast.com/t/8U8yMT4Dk

I then convert the uv pic (.tga) to the material of cod4. Using xconv(v1.51) convert the .obj to .xmodel_export. Last, create the xmodel using assets manager, but the model in radiant looks different from in blender - looks the screenshot notice the position of letter A and B in the shot below.

http://www.screencast.com/t/NnFpDI03

Offline kat

  • Administrator
  • Hero Member
  • *
  • Posts: 2361
Re: [COD4] uv mapping trouble
« Reply #1 on: November 20, 2010, 06:17:36 PM »
There could be a couple of reasons for that. In the UV/Image editor select all the face then in the Header menu select "UVs >> Scripts >> Save UV Face Layout", that will save a proper UV texture map rather than just using a screencapture (which is what you appear to be doing?).

Also when you export to OBJ make sure to "Apply Rot/Scale" (Ctrl+A), if you export the object from Blender without doing that it will revert to the position is *was* in before the mesh was moved, rotated and so on. You're not having done this may account for the misalignment.

You'll also need to check that the converter isn't switching axis and flipping things around.

Tags:
 

Sponsored Adverts
RSS Copyright © 2019 KatsBits™. All Rights Reserved. No part of this or associated properties shall be reproduced without prior consent. AdvertisePrivacy PolicyDMCA (about DMCA) • Copyright PolicyCopyright Contact Home Blog Support About Contact Site Search Site Map RSS feed Forum YouTube FaceBook LinkedIn Twitter Instagram IMVU