KatsBits Community

Isolate Ray Tracing by Object or by Layer?

0 Members and 1 Guest are viewing this topic.

Offline ACDmvmkr

  • Newbie
    • Posts: 47
 - Is there a way to turn off Ray Tracing on all but one LAYER when an image is being rendered?


 - Is there a way to turn off the Ray Tracing on all but a few selected OBJECTS in a scene which is being Rendered?

I have a complex scene where I have baked all the time costly details into all but two items. Rendered this way, all this background renders real fast.

But I have two items which I need to move thru the scene - a moving object, and the ground path it moves over.

Moved to a seperate layer with the light source, this object, it's ground path, and the ray traced shadow it casts on that path, renders decently fast when only that layer is turned on....but as soon as I activate the other layers, the Ray Tracer bogs down on all the other items that become visible when I activate the layers, dispite the fact that I've tried to de-activate them by playing with the settings such as making them "Shadeless", or unselecting the "Shadow" setting on them, or un-selecting the "Traceable" setting on them.

I have the two items I WANT Ray Tracing done on isolated to a separate empty layer, along with the single Ray Tracing light source. That light source has the "Layer" option activated, which I thought was supposed to keep all other items in the scene from participating in the ray tracing.

Set up this way, it does seem to stop the shadows from the other items from being DISPLAYED, but the computer does still seem to be wasting time on ray computing those objects, but just not displaying the result. My whole image takes the same time to render reguardless if I do the layer isolation routine or not.

My Goal - Render a scene of, say, 30 objects, while only doing time consuming Ray Tracing on 2 of them. How?


Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2718
    • KatsBits
From your description it reads like you're trying to get this to work relative to playback in the 3DView? If that's the case then yes, you're likely going to have performance issues due to "Blender Render" (standard 3DView driver) limitations.

With regards to rendering layers, if you're using 2.49 press the "Scene" button ("F10") and look for the "Render Layers" properties panel, the options there allow control over layers and what get's rendered. I don't know if you can render individual Objects unless they're on a dedicated layer, Blender has Layers as preferential rather than Objects.