KatsBits Community

[IMVU] Lighting problems with hair mesh

Jhaeza · 2 · 9295

0 Members and 1 Guest are viewing this topic.

Offline Jhaeza

  • Newbie
    • Posts: 17
Hello community,

I have some issues with an hair mesh, that I'm currently working on. It's not done yet but I wanted to see the parts I've done on IMVU. There are some problems with the lightning I suppose but I don't know why.

This is how it looks on Blender:


And this is the preview on IMVU:


There are some strands of hair, which show the texture correctly (brighter) and a few ones are darker. When I enable self-illuminating, it all works fine but I don't want it as an option.

So how can I change that? I don't know what I did wrong in Blender. There were some strands, which I rotated and stuff but they seem to work fine and the texture is actually working correctly, too. IMVU just makes them darker, then they naturally are.

I hope, that you can help me out with that.  :-X
Any help is appreciated. Thank You.

Cheers, Jhaeza


Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2655
    • KatsBits
That's generally due to Mesh Smoothing... The object/s is/are a single continuous surface which means the renderer can't figure out how surfaces should illuminate and shade (darken) relative to each other. This basically - https://www.katsbits.com/tutorials/blender/sword-mesh-smoothing.php

To solve you need to use "Sharp" edge markings and/or make sure they are applied ("Object > Apply") before export (if using FBX there's an option to "Apply Modifiers").

BTW, changed the topic title, you wrote "lightning" instead of "lighting"