KatsBits Community

Choose 0 Valued Axis

kat · 1 · 9469

0 Members and 1 Guest are viewing this topic.

Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2708
    • KatsBits
I got choose 0 valued axis during initial stage of BSP, couldn't find what it meant with search. Didn't have anything to do with the last number of brushes I'd placed, i think. Quite irritating as i can't continue, can anyone help me out? [fischu]

Answer: I'm not sure how valid a solution this is (I'm seriously guess-ti-mating) but that might be related to you using an axis of rotation on an entity set with '0' rather than 360 (which is the default '0'). Check your entities for a key/value pairing of angle/0.

A quick way to check entities is to open the map entity info browser (keyboard 'L') and go down the listing selecting each entry and reading what it says.. once you found the bad entity (assuming it is a '0' angle error) click the 'select' button and then 'close' the browser.

30b Question: Checked all entities, no angle/0 pairs. I found a light with an angle, but that didn't fix my error. Deleted and remade everything i did since last successful compile, still the same darn error. q3map2 disconnects after the error.

Sorry for posting this here, never came across such an error. I hope someone has.

Answer: what version of q3map2 are you using??

30c Question: Using latest? 2.5.11 something like that, d/led this week, doubt tho whether version of q3map2 really matters. It's probably something stupid, but I've got no idea where to start looking. your suggestion seemed like the most logical explanation. Isn't there some sort of listing, i mean whoever programmed q3map should know what it means, right?

Answer: The answer was in this thread funnily enough...

Code: [Select]
"************ ERROR ************
Chose a 0 valued axis A.

this error occurs when you try to cap a cone. The problem is that the top of the cone get's a 0*0 cap. so... remove the top (read small) cap of that cone [Hr.O]"

30d Question: The thing is, i haven't capped a cone since the last successful compile. I do recall thickening one by 2 units, would this have the same effect? Also I've already deleted everything I'd built since the last compile. Or would I have to do open it up in notepad and look for a patch with a 0*0? angle, I do hope there's an easier solution as I don't think I would know what to look for, patches I can recognize but the bunch of numbers under that I can not. thx for the help tho.

Answer: Do a quick test map, just a box with a cylinder mesh in it. Cap the cylinder and then try a compile (don't forget a player spawn as well), if you a clean compile then you know that 'cylinders' are generally ok and there is a problem with a mesh in the previous map file.

What the error actually means is in capping the cone (or cylinder) you've created a mesh section that is so small that it no longer has a valid size 'X' x 'Y' units. If you're still getting the error now then it means there *is* a mesh somewhere causing the problem. Thickening in of itself won't necessarily cause the problem so the best thing to try is to hide the patch related brushwork (Ctrl+P) and select/copy/paste everything else to a fresh new map file. Don't add any meshwork / cylinders to this file and just do a compile to check it's ok. Once you've done that, if it compiles ok, you can then either rebuild the patch work or copy/paste that stuff from the old file one mesh section at a time compiling a new file each time (so you can backtrack when you find the error) it's a bit of a long winded way to find the problem patchmesh but if you can't remember where it might have started to happen you have to be quite methodical in tracking it down.

You could probably track it down in notepad but the entry might not actually be '0*0' on the patch mesh. Open the map file any ways and have a look for a patchmesh func_group and see if you can find anything out of place.. make back up versions of the file as you work as you could total bork up the file by deleting entries like that.

30e Question: yeah, did it. Lazy as i am i tried to think of a quicker way, simply placed brushes where i had thickened the cones, and clicked on the select inside button. And as you said 2 tiny white lines/dots appeared. Hitting the backspace button really made me smile. Compiling sweetly now.