KatsBits Community

Help! Blender looks really bad on my new computer!

0 Members and 1 Guest are viewing this topic.

Offline ACDmvmkr

  • Newbie
    • Posts: 47
I usually use a combination of Blender 249b to compose on, and sometimes 272 to do vocal synchs on with it's f-curve burning capacity.

Just got a new gaming computer with a 6 core iCore5 CPU and a Nvidia 1660 Super graphics card.

The program seems to run well on it, doing all the old tasks about 4-6 times faster, so I'm happy there.

However, it looks really TERRIBLE on the new machine.

Everything in the workspace is terribly washed out, super overexposed and almost devoid of color.

All the renderings it does are similarly washed out and color faded, and instead of looking like the high quality imagery my old Dell Vostro PC used to put out, the renders look cartoonishly simple and just plain terrible. In fact, they tend to look more like the workspace depictions than the photo quality renders I used to get from my old machine.

I also find that the Blender program doesn't seem to want to save files on the new machine after I make changes.

My other programs, like SpaceEngine, etc, run and appear normally on this new machine.

My old machine was a Dell Vostro 220s with Intel Core Duo CPU and Nvidia Geforce graphics card, running Windows XP.

My new machine is a Cyberpower gamer with Intel iCore5 10400F 6 core CPU and Nvidia GeForce GTX 1660 Super 6GB graphics card, and 500GB PCI-E NVME SSD memory, running Windows 10.

How must I adapt this (Blender) to run well on my new machine?


Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2720
    • KatsBits
For reference can you post screen shots of what you're seeing with Blender on the old and new computers (use PrtScr or Windows Key + Shift + S)?

In the meantime, are you running the same versions of Blender on the new as well as old machines, if so this could be an OpenGL issue as Blender uses that as the primary rendering mechanism for everything it does, so the 1660 might be suffering an incompatibility of some kind - nVidia (still) doesn't seem to support OpenGL as well as AMD, preferring DirectX support instead.

Only thing to suggest is going into Preferences (Edit ยป Preferences) and having a look in the System and other panels to see if there's anything there that might help.