KatsBits Community

FBX: Mesh has 'no geometry'

Jhaeza · 4 · 6686

0 Members and 1 Guest are viewing this topic.

Offline Jhaeza

  • Newbie
    • Posts: 17
Hey there,

I got a quick question, that I can't seem to solve on my own.

I'm using Blender 2.78 and wanted to make a new beanie for males. Started with one of the older avatar files (if that's important to you). Everything is working fine in Blender. The beanie is moving perfectly with the head and is clearly attached. I exported the file as fbx and went over to IMVU. I picked up the "Empty Male Clothing" product for this matter and used the Mesh-ID 0. The applied scale is 0,01 and I made sure to select/deselect all the right things in Blender to make it work in iMVU.



Yet, when I specify an ID (0), apply the scale and hit import, I get this error:



When I click on "Import Changes" nothing happens. It's like I never imported anything in the first place.

I hope, that you can help me out with that. Thankful for every help!

Jhaeza


Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2583
    • KatsBits
Try deselecting everything before export (nothing should be highlighted in the Scene) as that sometimes helps with missing data. Make sure you're using the Accessory Starter File if you're making a typical accessory item, the Parent for the mesh is AttachmentRoot, not Head as it would be if you use the Clothing Starter File - you'd also need to derive from Accessory rather than Empty Fe/Male.


Offline Jhaeza

  • Newbie
    • Posts: 17
First of all, thanks for the quick reply but it doesn't seem to work. I did everything you mentioned above and also tried to do a female beanie (following your YouTube tutorial from start to end). Yet, whatever I do, my objects do not have "geometry" according to IMVU. Any other guesses with this one?



Offline kat

  • Administrator
  • Hero Member
  • *
    • Posts: 2583
    • KatsBits
Which Starter File did you use (for 2.79 and below make sure to be always using these)? And just to clarify, you built and exported the project in Blender 2.78? You did not Append contents from a Blender 2.8+ file into 2.78?