KatsBits Community

Game Editing => General Content Creation => Topic started by: cuetip on January 11, 2011, 08:17:28 AM

Title: [Q4] Map Editing Trouble
Post by: cuetip on January 11, 2011, 08:17:28 AM
I was editing a stock Quake 4 map that has two parts to it. You start off in the base, then go to a different map from that base, then return to the same map (storage1 to storage2 then back to storage1 again). A few of the models are in different positions when you return. I can't seem to figure out how to delete the first phase models.

The second phase models show up fine in radiant and I can delete them, but the phase one models don't seem to exist. Whenever I load the map via console (map game\storage1) it starts me off on the second phase and not the first... I know my editing worked to some extent as the models I deleted are no longer present in the second phase. When I load the map up in the editor I can't find any trace of the first phase models. I literally looked at every single entity entry (took hours).

I had storage1 load via normal gameplay progression and the console said that it loaded storage1. I played through the first phase, went to the next map (storage2) from phase one, and returned back to storage1, enter phase two. I kept track of which map the game was loading via console. Phase 1 and phase 2 are both in storage1. The models I deleted in phase 2 were gone like I expected.

I looked at all the single player map scripts and there is only one script for storage1. Storage2 script doesn't contain any data on storage1. I didn't find any "helper" scripts for storage1 either. So why do you think I can't find the first phase models in radiant and only the second? Do you know how I could?

[edit] edited post so it wasn't a big wall of text. kat
Title: Re: Quake 4 Map Editing Trouble
Post by: kat on January 11, 2011, 08:42:34 AM
Make sure you unpack all the PK4 files (if you have space for it) before working on this - to an outside directory if you can. The trouble with Q4 is that assets are all over the place depending on who made them and so on, not just map or level location - that means looking at the scripts won't necessary tell you where something is physically. This 'missing' assets are a pain to track down unfortunately.

Also make sure to be loading the levels using the "developers" command, can't remember what that was for Q4 so you'll need to search the 'iNet for those, that prevents (should) levels loading in based on gamesaves.
Title: Re: Quake 4 Map Editing Trouble
Post by: cuetip on January 11, 2011, 09:27:05 AM
When I unpacked the stock Quake 4 maps, I unpacked everything associated with that map (i.e. aas files, cm, proc, and even reverb). Did you mean I should unpack every single pk4 archive o_O? The thing I don't understand is how those models aren't showing up in radiant...It's to my understanding that that all a compiled map does is provides coordinates and a layout for the game engine to deploy specified and associated resources, creating a level. I don't mean any disrespect, but I don't see how extracting every single pk4 archive would make those "invisible" entities show up... Although the game's resources contain a certain model, it has to be called upon by the map to show up in the game, right? Well if those models aren't listed as something to be used in the map, how can it show up? I might be missing something though, so again, I apologize for my ignorance  :-X
Title: Re: Quake 4 Map Editing Trouble
Post by: kat on January 11, 2011, 09:43:14 AM
Yes, unpack everything. They won't show up in Radiant because they're probably script references that are being swapped at run-time; you'll only see the original 'place-holder' in the editor, which could be a model, entity or brush object.
Title: Re: Quake 4 Map Editing Trouble
Post by: cuetip on January 11, 2011, 11:20:25 AM
I tried unpacking all the pk4 archives until I was asked to overwrite files...I cancelled the operation because I wasn't sure. Am I supposed to unpack every pk4 archive or just the ones containing the maps? Also, I bought the censored version of Quake 4 and plan to use the censored models. I won't be distributing the mod to anyone (I doubt anyone is bothered by those biomachines anyway lol). If I place those models into an override archive using the same directory structure as the original pk4's, they should appear in the game, right? They most likely have the same names as the original models, but if they don't I'll try renaming them and see what happens. According to the screenshots in this article (http://www.schnittberichte.com/schnittbericht.php?ID=3229) the models I'm replacing are the same except they have covers over them, so I think it will work. If not I'll manually add them to the maps myself.
Title: Re: Quake 4 Map Editing Trouble
Post by: kat on January 11, 2011, 12:14:14 PM
You need to unpack all the assets packs. Like I said above, the assets are not all in their most logical location so tracking down the actual models being used can be tricky.

With regards this being a 'mod' that you release.. there's no point unless those 'censored' assets are contained in the default content because yes, you cannot distribute content from one version because said material isn't in another.

For your own purposes though you should be able to drop the PK4 from the censored version into the uncensored and have it overwrite the appropriate material  (mind you it will do that to everything else that's been overridden unless you find the specific models. It's a fiddly process to get working either way.
Title: Re: Quake 4 Map Editing Trouble
Post by: cuetip on January 11, 2011, 12:31:37 PM
Which ones are the "asset packs"? As for the censored version, I'd imagine the original models won't even be in included in the censored release. I know what each of the models is called though. There are only a few anyway.
Title: Re: Quake 4 Map Editing Trouble
Post by: kat on January 11, 2011, 02:07:52 PM
Any PK4 containing models, textures, material that's loaded into the game is an "asset", so unpack all of those; you're looking for a model and as I've already said, they're not in logical places which means you have to unpack everything (or as much as you can).
Title: Re: Quake 4 Map Editing Trouble
Post by: cuetip on January 11, 2011, 04:21:45 PM
So you're saying if I unpack the assets, the invisible models in the map will somehow appear in radiant? Could you explain how that works? Why doesn't radiant get the models from the pk4 files while the map is being edited like every other map?
Title: Re: Quake 4 Map Editing Trouble
Post by: kat on January 11, 2011, 05:15:24 PM
If all you're trying to do is get one set of assets to appear in place of another you should be able to simply drop those into the installation directory using the PK4 naming convention like I said before (via facebook) to have those 'overwrite' the defaults, you shouldn't need to mess around in Radiant. If that doesn't work then you have to unpack the files to 'force' Radiant to use the correct files (which may then mean you having to recompile maps) - in theory if Radiant still uses the defaults even when editing the censored version of the game, it means that (as mentioned before) that the game is run-time script swapping assets, replacing the defaults with the 'fixed' version.
Title: Re: Quake 4 Map Editing Trouble
Post by: cuetip on January 11, 2011, 05:49:02 PM
I just ordered the censored version (which will most likely take weeks to get to me because it's coming from Germany). What I've been doing is deleting the select models from the maps that contain them and then recompiling them. I've been able to locate every model in every map except for this one. I'm only able to find the models from phase2 of the map, not phase1 for some reason. I understand how to override assets but that's not what I'm doing right now. The only thing I'm overriding is the edited maps (which does work). But what I don't understand is why the phase1 models don't appear in radiant in the entity list. I looked at every single entity even though it took me a few hours. I could not find the first phase models. Every time the map is loaded, be it via normal game progression or the console (devmap game\storage1), those first phase entities are there. When I progress to phase2 the models that I deleted in radiant are gone as expected. Again, my problem is that I can't seem to find the entities from phase1 in radiant. Do you know anything about maps like that? A map that has brushes and models that are moved or removed after returning to the map from a different map in-game?
Title: Re: Quake 4 Map Editing Trouble
Post by: kat on January 11, 2011, 06:55:52 PM
As I've been saying, that sounds like the assets are being removed and replaced using a script which is why they don't show up in Radiant, they won't if the editor doesn't have them registered in the entity list. The fact that it's being done for censorship reasons makes no odds as it uses the same process as normal game triggered events. If the assets are there in game then you've simply not found them yet...  It could also be that the models are "inline" which means they're compiled into the map itself, again another reason why they won't necessarily show in Radiant.

Having said all of that though, if I were you I'd just step away from this for a few days and come back to it with fresh eyes, right now all you're doing is getting frustrated and going round in circles, which obviously doesn't help.
Title: Re: Quake 4 Map Editing Trouble
Post by: cuetip on January 12, 2011, 05:20:56 AM
I haven't worked on this for mod for days. And I'm not frustrated, just curious  ;)

EDIT: I redid storage1 saved it, compiled it, and had the map load normally from the end of mcc_2 and everything I deleted was gone :) My mod is just about finished now. I just have to make a few screenshots for some edited levels, package it all up, and I'm done :) Thanks for the help. I'm not really a modder, but when I'm doing something new like map editing, I like to know why something is, not just how to do it ;)