KatsBits #Blender #Gamedev

Game Editing => IMVU Content Creating => Topic started by: wildlion on July 01, 2010, 07:39:07 PM

Title: [IMVU] vertex error message in Blender
Post by: wildlion on July 01, 2010, 07:39:07 PM
I got problem with blender that makes ma mesh invisible in the previewer of imvu (virtual 3D world). When I was exporting my mesh and armatures with cal3D i found some warning that says that vertexes are 0.0 and if it divided by that number it will be zero. and I need to check vertexes. actually I dunno what that means but would like to get help so as i can do my mesh  (furniture). anyone can help me please?
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 01, 2010, 11:24:10 PM
That usually happens when the mesh doesn't have any vertex groups assigned to it. Or, if it does, they're not correctly named - the group has to have the same name as the bone that's associated with them (http://www.katsbits.com/smforum/index.php?topic=124.0), so for a simple bit of furniture that would be "Root" if you were using KatsBits example file.

OT: When you post try to avoid using 'txt' speak and spell check before hand (the forum has that feature built in but if you have Google Toolbar that has one as well), it just helps those that don't speak English as a first language understand what's being discussed.
Title: Re: [IMVU] vertex error message in Blender
Post by: pazur on July 02, 2010, 02:18:48 AM
Google Toolbar is evil... I use the spell check of Firefox.
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 02, 2010, 02:56:58 AM
Google Toolbar is evil... I use the spell check of Firefox.
It is yes, but not all browsers has a native checker.
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 03, 2010, 01:44:23 AM
finally it worked but the mesh and the armatures (also standing node) are parallel to  the floor not perpendicular like norlmal, any idea how i can fix that?
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 03, 2010, 02:35:14 AM
You mean they're lying on their back? Take a screenshot and post here if you can. At a guess though that's probably going to be related to not 'fixing' the position of the objects (http://www.katsbits.com/smforum/index.php?topic=128.0) before you exported. Have a look at the IMVU videos in the YouTube section of the forum (http://www.katsbits.com/smforum/index.php?board=8.0), those will help you figure out what's going on.
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 03, 2010, 02:56:49 AM
u mean the ctrl+a? i do that but weird menu pop up i am sure it's not ctrl+a and if it is what i should choose from the 4 choices?
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 03, 2010, 03:09:47 AM
If you've got four options showing it's "Scale and Rotation to ObData". You need to make sure to *unparent* the mesh from the armature before doing that though. Reparent once applied.
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 03, 2010, 03:23:12 AM
did everything u said then began new project with ur template but still same problem :/
(https://www.katsbits.com/smforum/proxy.php?request=http%3A%2F%2Fi50.tinypic.com%2Fpt8g5.gif&hash=bd74597a13e01e697c086f7ea284e185)
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 03, 2010, 03:45:38 AM
Ok, you need to follow this next bit to the letter. First the reason why that happened (so you know what it is when it happens again). That problem crops up as a result for one of or both of the following reasons,

Doing either of those will screw up the eventual rotation. So, to fix. If it's;

If you still have problems then you're probably missing another step somewhere or doing something else that's 'breaking' the exported results - it's *very* easy to do that by the way. You've got to be quite methodical when it comes to this stage of the process to make sure you've got everything set up correctly.
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 03, 2010, 03:54:41 AM
Thought about taking a pic for ma mesh and nodes maybe u find sumthing in it and thanks so much for the help

and no i joined the avatar rig to the furniture rig (to  be light pink)
(https://www.katsbits.com/smforum/proxy.php?request=http%3A%2F%2Fi49.tinypic.com%2F25ul5d1.gif&hash=a666e1d2d9393808bb34edb97f7fbd52)
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 03, 2010, 03:18:57 PM
Yeah, that's likely going to be reason "A" mentioned above, you need to rotate the standing pose spot bones slightly (by at least one degree) so they're not at right angles to the grid. Select the pitcher, catcher, handle and *.standing bone and rotate them as a group.
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 03, 2010, 08:51:42 PM
on x or y or z tho? i tried normal rotate on x but it didn't work :/
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 03, 2010, 09:20:18 PM
"Z". Just go into 'top' view and rotate that way, that locks you to the correct axis around which to rotate.
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 03, 2010, 09:34:21 PM
(https://www.katsbits.com/smforum/proxy.php?request=http%3A%2F%2Fi50.tinypic.com%2F152e4qe.gif&hash=16deb12597871bca1e7f59c6e0eae652)

did what u told me but still same problem. da pic will show how it is rotated tho
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 03, 2010, 10:07:45 PM
Have you parented all the bones to the "Root" bone once you've joined all the armatures? What version of Blender are you using? And are you using a third party script to export with?
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 03, 2010, 10:24:36 PM
what u mean by parented all bones to root bone? i already select the mesh then the root bone which at that time it selects all other avatar bonest as they are joined then parent to armature. for blender version i use version 2.49 and the eporter is neo's blender to imvu exporter and dats all.
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 03, 2010, 10:43:30 PM
Ok, go and read the furniture tutorial again (http://www.katsbits.com/tutorials/imvu/make-furniture-products-with-blender.php#how_to_use), I've made an amendment and updated it as that step is missing for some reason - could have sworn I had it in that tutorial - pay attention to what you have to do after you've joined all the armature sections together. Watch this (http://www.katsbits.com/smforum/index.php?topic=126.0).
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 03, 2010, 11:36:52 PM
followed every step but still. I am fedup lolz seems there is no way to do that :/
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 04, 2010, 05:18:25 AM
Ok, drop back to Blender 2.45 (http://download.blender.org/release/Blender2.45/) and try it from there (you may need to install Python version 2.5.x (http://www.python.org/download/releases/2.5.4/) as well). The chances are that it's the script causing issues, assuming you've done everything correctly, I had this same problem when trying it with 2.49 as well so just stuck with 2.45 and the included exporter.
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 04, 2010, 11:25:40 PM
worked with me well now actually and trying to do uv mapping so as i can put 2 textures on every faave of the mesh
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 05, 2010, 12:42:13 AM
worked with me well now actually and trying to do uv mapping so as i can put 2 textures on every faave of the mesh
So what was it that was 'broken', you fixed it by doing...? It's always a good idea to follow up with what you did to get it to export properly so others reading this will know what to do under similar circumstances.
Title: Re: [IMVU] vertex error message in Blender
Post by: wildlion on July 05, 2010, 01:53:26 AM
last time i didn't rotate the standing nodes for 1 degree as u told me + parenting avi armatures with root one + DELEting the body bone << believe that not deleting body armature can cause this problem.

Thanks much for ur help
Title: Re: [IMVU] vertex error message in Blender
Post by: kat on July 05, 2010, 02:33:32 AM
Interesting.. that shouldn't normally cause a problem so long as the 'body' bone is correctly parented to the root bone like the others because all it does is export the bone as part of the rig - it just doesn't influence anything. Anyway, glad you got it sorted out properly.